CICS TS

Version: 41

Overview

CICS® Transaction Server for z/OS provides scalable, general-purpose, transaction processing solutions for high-volume updates to shared data. Businesses have used CICS to differentiate themselves by creating, extending, and evolving their critical applications.

You can use steps from the CICS TS plug-in for UrbanCode Deploy, in combination with other plug-ins, to automate the deployment and undeployment of CICS applications.

In a wider context, the CICS TS plug-in can be used in conjunction with other CICS tooling to automate the build and deployment of CICS artifacts as part of a continuous delivery environment.

Compatibility

Platform Support:

The CICS TS plug-in is supported to run against any of the following CICS editions:

  • IBM CICS Transaction Server for z/OS V4.1 through V5.5
  • IBM CICS Transaction Server for z/OS Developer Trial V4.2 through V5.5
  • IBM CICS Transaction Server for z/OS Value Unit Edition V5.1 through V5.5

Additionally, you must also have configured a CICS management client interface (CMCI) port, as described in topic Setting up access for CICS Explorer in the IBM Knowledge Center.

This plug-in requires UrbanCode Deploy 6.2.5 or later, and the zOS Utility 10 plug-in or later. Using this plug-in requires the UrbanCode Deploy agent to be running with Java 8; for details of how to upgrade the version of Java used by the agent, see Changing or updating the JRE of agents.

Step Support:

CICS TS V5.1 or above is required for the following CICS TS plug-in steps:

  • Enable application, Disable application

 

CICS TS V5.1 or CICS TS V5.2 with APAR PI56706, or CICS TS V5.3 or above is required for the following CICS TS plug-in steps. These steps also require the UCD agent to run in the same sysplex as the target CICSPlex SM CMAS region:

  • Deploy bundle, Undeploy bundles
  • Deploy application, Undeploy application

 

CICS TS V5.3 or above is required for the following CICS TS plug-in steps:

  • Phase in resources for the resource type of Bundle

 

Installation

No special steps are required for installation. See Installing plug-ins in UrbanCode Deploy.